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Welcome to SoftChalk LessonBuilder 

Overview 

SoftChalk™ LessonBuilder is a powerful web lesson editor that lets you easily create engaging, 
interactive web lessons for your e-learning classroom. 

LessonBuilder allows you to create and edit content as if working in a word processor.  You can 
perform basic text editing, such as adding bold, italic, colored text, bullets, tables and hyperlinks 
to your lesson document.  In addition, in-line comprehension questions can be easily added to 
your lesson.  Pop-up annotations and notes are easy to create, as are simple, interactive learning 
games.  
  
With LessonBuilder’s built-in style properties function, you can choose from over 65 style designs.  
With the click of a button, LessonBuilder will generate a set of integrated lesson pages, with built-
in navigation and a professionally designed layout.  LessonBuilder supports the creation of multi-
page lessons, with automatically generated inter- and intra- page navigation, as well as several 
options for creation of a Table of Contents. 
 
LessonBuilder lessons are created in standard HTML format.  Your students will be able to view 
your LessonBuilder lessons in any standard web browser. 
 
When you’re finished creating your lesson, use LessonBuilder’s “Package” feature to 
automatically package your lesson files into a zip file that can be easily imported into most 
Learning Management Systems (LMS), such as Blackboard and WebCT.  You may also package 
your lesson in a SCORM (1.2 or 2004) format for import into any SCORM-compliant LMS. Or, 
simply distribute your lesson by copying the lesson folder to a CD, a file server, or a web server.   
 
The next sections describe in detail how to use LessonBuilder 3.  If you have questions, 
problems, or comments, please contact: help@softchalk.com

SoftChalk LessonBuilder 3 Users Guide  Page-1 

mailto:server-support@wimba.com


SoftChalk LessonBuilder 3 Users Guide 

 

System Requirements 

SoftChalk LessonBuilder may be installed on Windows computers (Win 98, ME, 2000, XP), or on 
Macintosh OSX.   Below are the system requirements for SoftChalk LessonBuilder: 

• Authoring (Instructor) 
o Windows 98, ME, 2000, XP  

 Supported Web Browser, including IE 5.5 or above, Netscape 6.x or  
above, Mozilla/Firefox 

 Java Runtime 1.5.x or above 
 Flash Player 8 or higher 

o Macintosh OS X  
 Supported Web Browser, including Apple Safari 1.x or higher 
 Flash Player 8 or higher 

• Student 
o Windows 98, ME, 2000, XP  

 Supported Web Browser, including IE 5.5 or above, Netscape 6.x or  
above, Mozilla/Firefox 

 Flash Player 8 or higher 
o Macintosh 9.x or OS X  

 Supported Web Browser, including Apple Safari 1.x or higher 
 Flash Player 8 or higher 

o Macintosh 9.x or OS X  
 Supported Web Browser, including Apple Safari 1.x or higher 
 Flash Player 8 or higher 

 

Installation 

Please see the SoftChalk LessonBuilder 3 Installation Guide for information about installing 
LessonBuilder 3.  This guide is available at the SoftChalk website (www.softchalk.com) under the 
Support area. 
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Getting Started with LessonBuilder 
The following sections provide information about how to create a simple lesson that demonstrates 
some of the features of LessonBuilder. 

Creating, Opening and Saving a Lesson 

Creating a Lesson 

To begin creating your first LessonBuilder document, simply start the LessonBuilder 
program, and begin typing. 

LessonBuilder starts up with a blank document displayed. Click your cursor in the editing 
window and begin typing – just as if you were using your favorite word processing 
program. 

Opening a Lesson 

To edit an existing LessonBuilder file, choose the File menu, Open. 

A window will open to let you choose documents of type "html."  

LessonBuilder documents are saved as type "html." You will need to locate the 
html document that you previously created and saved using LessonBuilder.  

NOTE: If you open a document that was not created by LessonBuilder, you will 
receive a warning message. The document may lose formatting and may 
become unusable if you save it using LessonBuilder.  

If you open a non-LessonBuilder document, simply close the document without 
making any changes and without saving it. 

 

Open Recent 

To open a LessonBuilder lesson that you recently worked on, choose File menu, Open 
Recent. LessonBuilder will display a list of the eight most recent lessons that you have 
edited.  If this list does not display the lesson that you wish to edit, try using the 
File/Open menu options as described in the previous section.  

 

SoftChalk LessonBuilder 3 Users Guide  Page-3 



SoftChalk LessonBuilder 3 Users Guide 

 

Saving a Lesson  

Choose the File menu, Save or Save as...  

If you have not previously saved your LessonBuilder document, you will be 
prompted to provide a name for your LessonBuilder document. On subsequent 
saves of the document, LessonBuilder will save the document without prompting 
you for the name of the document.   

The Save as... option lets you save your document to a different document 
name.  

Previewing a Lesson  

At any time while you are editing your lesson, you may preview it to see how it 
will look to your students in their web browser. 

Choose the Preview menu, Preview Document, or click the Preview toolbar 

icon.   

Preview displays the document in your default web browser. Save your 
document changes before previewing to ensure that you are viewing the latest 
version of your document.  

SoftChalk LessonBuilder 3 Users Guide  Page-4 



SoftChalk LessonBuilder 3 Users Guide 

 

Basic Text Editing 

You will find most of the standard text editing features in LessonBuilder. Here we describe a few 
of the options. 

LessonBuilder Toolbar and Menus 

Many of the editing actions can be selected from the LessonBuilder Toolbar (below). 
 

 
Figure 1: LessonBuilder Toolbar 

 
Or, make selections from the LessonBuilder Menus (below). 
 

 
Figure 2: LessonBuilder Menu Bar 

Fonts 

1. Start by typing your text.    

2. Select some of the text using your mouse. 

3. Choose from the Font Type and Font Size options located at the top left of the 
LessonBuilder Toolbar (see Figures 1 & 2).   
 

4. Alternatively, you can start by choosing from the Font Type and Font Size options, 
and then begin typing.  

 

 

 

 

Figure 3: Font and Size Menus 
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Headings 

 
Highlight the text you want to format using your mouse. 

1. Then select the Heading option in the upper right corner. 

2. The largest heading is Page Heading, the smallest is Sub-Heading 2. 

3. To return the text to normal size, select "Plain Text".  

 

 

 

 

Figure 4: Heading Menu 

 

Bullets and Lists 

1. Type the text that you want to be bulleted. 

2. Press ENTER after each line of text if you want to insert multiple bullets. 

3. Highlight the text using your mouse. 

4. Click the "Toggle Bullet List" or "Toggle Number List" button on 
the toolbar.    

5. To add additional bullets/numbers in a list, press the Enter key when the cursor is in 
a list. 

6. Exit the list by pressing the down arrow or clicking below the list.  

Alternatively, you can start a new list by clicking the Bullet or Number button before 
typing.  To remove a list, highlight the list using your mouse. Then click the Bullet or 
Number button. The formatting will be removed but the text will remain.  
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Text Formatting 

1. Choose the "Bold," "Italic," or "Underline" button on the toolbar.  

2. Begin typing.  

3. Alternatively, you can highlight text using your mouse. Then choose one of the 
formatting buttons.  

 

Special Characters / Math Characters 

 

1. Choose the Insert menu, Special Characters or Math Characters. 

2. Click the symbol that you want and it will be inserted at the location of the cursor.  
 

3. You can leave the Special Characters and Math Characters windows open while 
editing your LessonBuilder document. 
 

 

 

 

 

 

 

 

 

 

 

 

Figure 5: Special Characters Menu 
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Tables 

Tables are inserted at the location of your cursor. 

1. Choose the Table menu option, and then choose Create Table.  

2. The Table dialog lets you select the number of rows and columns and many other 
options. 

 

 
Figure 6: Insert Table Dialog Window 

 

3. Make your selections and click the OK button to insert the table into the lesson. 

4. The options available for selection in the Table Dialog will vary depending on the type 
of Style Properties you have selected for your lesson.   

5. If you have applied a Banner or Custom Style, you may choose to insert a styled 
table by checking the Use Styled Table option in the dialog.  Or, you may choose an 
unstyled table by un-checking the Use Styled Table option in the dialog.  A styled 
table inserts a table that has pre-defined cell and border settings, and background 
colors. 

6. If you have not applied a style, or if you have applied a Basic Style, you will not have 
the Use Styled Table option available.  When inserting an unstyled table, you may 
set the border, cell and background color options using the Table dialog options. 
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7. To modify an existing table in your lesson, place your cursor within the table, choose 
the Table menu, Modify Table.  The table dialog will re-appear with the settings for 
the existing table.  You may modify the settings.  Click OK to save the settings 
changes. 

8. You may insert a table within a table.  First, create a table.  Then, place your cursor 
in one of the table cells where you wish to insert a new table.  Then, choose the 
Table menu, Insert Table. 

9. To modify the number of rows and columns, or the table headers, place your cursor 
within the existing table, then choose Table menu and the appropriate action (Insert 
Row or Column, Append Row or Column, Delete Row or Column. 

10. To make a cell a row or column header, place your cursor within the appropriate cell 
of the existing table, then choose Table menu, Make Column Header (Make Row 
Header).  There is also an option on the table menu to Remove Header. 

11. HINT: When inserting a non-styled table, start with a table border size of at least 1. 
With a border size of 0, the table’s borders will not be visible. After entering text into 
the table, you can set the border size to 0 if you do not wish to have the table borders 
visible. 

 

Copying and Pasting Formatted Text 

When you paste formatted text from Microsoft® Word, html documents, or web pages 
into LessonBuilder, you may either keep the formatting of the text, or paste the text as 
plain text which will remove the formatting 

To keep the formatting, use the Edit menu, Paste option.   

To remove the formatting and paste as plain text, user the Edit menu, Paste as Plain 
Text option.  

Use the shortcut keys Ctrl-C for copy, Ctrl-V for paste.  The shortcut key for pasting will 
paste your text and keep the formatting.   

You may also drag text from Microsoft® Word, html documents, or web pages directly 
into your LessonBuilder lesson, and drop the text.  The text will be copied and pasted 
along with the formatting. 

SpellChecking 

1. Choose the Tools menu, and then choose Check Spelling. 

2. A window will open that has options for spell checking. 

3. If the Spell Check dialog opens and immediately closes, then there were no mis-spelled 
words found by the spell checker. 
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Figure 7: Spell check Dialog Window 

 
4. If the Spell Check dialog opens and immediately closes, then there were no mis-spelled 

words found by the spell checker. 
 

5. If the Spell Check dialog finds a word that is not in its dictionary, you will be prompted 
with a suggested word to change to.  Click Change to make the suggested change.  
Click Ignore to ignore the suggested change.  You may also type the change you wish to 
make into the Change to dialog and then click the Change button to update your lesson. 

 

Inserting Images into your lesson 

1. To insert an image into your lesson, place your cursor at the location in the lesson 
where you wish the image to appear. 

2.  Click the Insert Image button    on the toolbar to open the Insert Image window. 

3. Click the Select image... button. 

4. Choose an image using the file dialog window that appears.  Once you have selected 
an image, click Select. The image will appear in the Insert Image dialog.   

5. Customize your image using Align Image, Border, Alternative text, Long 
description, Height, and Width. 

6. Click OK to insert the image into your lesson.  

7. To modify an existing image in your document, click on the image. Then right-click 

your mouse, or click the Insert Image button  on the button bar. The Insert 
Image dialog will display with your image showing. Use the dialog to modify, replace, 
or remove the image.  

SoftChalk LessonBuilder 3 Users Guide  Page-10 



SoftChalk LessonBuilder 3 Users Guide 

8. To make an existing image a hyperlink, first click on the image. Then right-click your 

mouse and choose Insert Hyperlink, or click the Insert Hyperlink button  on the 
button bar. Complete the hyperlink dialog as described in the next section.  

 

Figure 8: Insert Image Dialog Window 
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Advanced Features 

Adding Hyperlinks to your lesson 

Inserting hyperlinks is best explained by example. Here's how to put a link to the 
SoftChalk web site into your document. 

1. In your document, type the text "SoftChalk Web Site."  Select the text "SoftChalk 
Web Site" by dragging your mouse over the text to highlight it. 

2. Click the Insert Hyperlink button    on the toolbar to open the Insert Hyperlink 
dialog window. 
 

 
Figure 9: Insert Hyperlink Dialog Window 

 

3. Notice that "http://" is already in the URL text box. Type "www.softchalk.com", the 
remainder of the URL, into the text box. (For other types of links, click in the "URL 
Protocols" window to start the URL). 

4. Click the checkbox "Open the link in a new window." This will make your link open a 
new browser window when the link is clicked.  Click the "Insert" button. 
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5. To modify an existing hyperlink in your document, select the text associated with the 
link. Click the "Insert Hyperlink" button. The Insert Hyperlink window will open. Now 
you can modify, replace, or remove the hyperlink. 

6. To insert a link to a file on your computer, repeat steps 1, 2, and 3. Then click the 
"Select file..." button. Choose a file in the window that appears and click "Open." 
Click the OK button to finish.  
 

Adding Text Annotations (TextPopper) 

Use the TextPopper feature in LessonBuilder to add pop-up text annotations and text 
definitions within your text.   

1. Within your LessonBuilder document, type some text.  Then, highlight the text you 
wish to annotate. 

2. Choose the Insert menu, TextPopper. 

3. In the TextPopper dialog window, fill in only the left text area to display a note. Fill in 
both the left and right text areas to display an annotation. 

 

 

Figure 10: TextPopper Dialog Window 

 

4. Within the TextPopper dialog window, you may right-click in the Bottom Area and 
Top Area text boxes to display a text-editing menu that will allow you to format your 
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text for bold, italic, etc.  This right-click menu also allows you to insert a hyperlink into 
the TextPopper text.   

5. You may also click within the TextPopper Bottom Area and Top Area text boxes, 
and then click the TextPopper Special Characters and Image buttons to add those 
to your TextPopper text. 

6. Select additional TextPopper features by clicking the check boxes and radio buttons 
associated with those options in the dialog window.  Select to add a dropshadow, 
locate the position of the TextPopper, select the width of the TextPopper display, or 
to make your TextPopper “sticky”.  Sticky TextPoppers remain open in the text until 
closed by the user.   

7. Click OK.  

To modify or remove a TextPopper, click so your cursor is located within the TextPopper text in 
your document.  Then, choose the Insert menu, TextPopper. In the TextPopper window make 
changes and choose OK to modify the TextPopper, or click the Remove button to delete the 
TextPopper from your document. 

 

Adding Self Check Questions (QuizPopper) 

Use the QuizPopper to add in-line comprehension questions. There are six types of 
questions: true/false, multiple choice, multiple answer, short answer, matching, and 
ordering. 

Click to position your cursor within your lesson at the location where you wish the quiz 
question to be inserted. Choose the Insert menu, QuizPopper. Then, select the type of 
question you wish to insert. 

1. In the Q & A tab, enter your question or statement. Then provide answer choices and 
select the correct answer. 

2. Within the QuizPopper dialog window, you may right-click on most of the text boxes 
where you type questions, answers, feedback and hints.  A right-click will display a 
text-editing menu that will allow you to format your text for bold, italic, etc.  In 
addition, if you click within the QuizPopper text boxes, you can then click the Insert 
“Special Characters” and “Insert Math Characters” buttons to add those characters to 
your questions, answers, and feedback. 

3. In the Feedback tab, you may enter feedback for right and wrong responses. 

4. In the Hint tab, you may choose to make a hint available. 

5. In the Options tab, you may set the link icon or text, and choose to hide or show the 
question when your lesson is opened.  There are also options to set the question 
value, and the type of feedback display.  
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6. Choose OK when you are finished. 

 

Figure 11: QuizPopper Dialog Window 

 

7. To modify or remove a QuizPopper, within your document, click on the QuizPopper 
link icon, or place your cursor in the QuizPopper text link. Then, choose the Insert 
menu, Modify Question or Remove Question.  You may also right-click to display 
these options after selecting the QuizPopper link in your text. 

8. QuizPoppers are placed on their own line in the lesson.  After making several 
questions, you can highlight them and put them in a list (see Bullets and Lists 
above). You may also create a Table and place QuizPoppers within the cells of the 
table. 

 

Adding Learning Activities 

 

Use LessonBuilder’s Activity features to add interactive activities to your lesson. Activities include 
Crossword Puzzle, DragNDrop Matching, Flash-Cards, Hot Spot Explore, Hot Spot Quiz, 
Labeling Activity, Ordering Activity, Seek-a-Word Activity, and Ordering. 

1. To insert an activity, place your cursor at the location in your lesson where you wish 
to have the activity appear.  Then, choose the Insert menu, Activity.  Then choose 
the type of to add. 

2. Each Activity has its own Help tab with instructions on how to create the activity. 
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Figure 12: Activity Dialog Window 

 

3. Complete the dialog menus for the Activity. Then click OK when you are finished, to 
insert the activity into your lesson. 

4. All of the activities have a Display Inline checkbox that can be checked if you wish to 
have the activity appear “in-line” with the text of your lesson.  Do not check the box if 
you would rather have the activity appear as a link in the text of your lesson.  Look for 
the Display Inline checkbox on the Options tab (or on the initial dialog window if 
there is no Options tab for the activity). 

5. Several of the activities allow you to use the Browse button within the activity dialog 
to read-in a number of item entries at once.  For information abut formatting the text 
file needed to import these entries, please see the Help tab on the dialog window for 
the activity.   
 
Also, before using the Browse option, it is usually a good idea to first create a couple 
of items for the activity by typing the information into the dialog window.  Then use 
the Export List option.  This will create a text file with the correct formatting.  You 
can use this text file as an example for how to format additional items that can then 
be imported into the activity using the Browse button. 
 
 

6. To modify or remove an Activity, within the lesson document, right-click on the 
activity’s icon.  Alternatively, you may click on the activity’s icon within your 
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LessonBuilder document, then, choose the Insert menu, and select either Modify 
Activity or Remove Activity.  

 

Insert Audio/Video Hyperlink 

1. You may insert an audio or video hyperlink by choosing Audio/Video Hyperlink from the 
Insert menu. 
 

2. From the dialog window that is displayed, select either Audio or Video hyperlink as 
appropriate.  Then, use the browse button to locate the audio or video file you wish to link 
into your document.  Or, enter the URL of the audio or video hyperlink into the dialog 
textbox.   
 

3. Click OK  
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Styling Your Lesson 

LessonBuilder’s Style Properties options allow you to apply a styled format to your 
lesson to produce a professional-looking lesson.  With LessonBuilder’s built-in style 
features, you can choose a style design template, and page navigation options; then 
quickly generate a set of integrated lesson pages, with built-in page navigation and a 
professionally-designed layout. 

Style Properties 

To select Style Properties, choose the Properties menu, then Style Properties.  The 
Style Properties dialog window will be displayed. 

 
Figure 13: Style Properties Dialog Window 

 
1. To apply a style to your lesson, scroll thru the Style Choices; to preview a style choice, 

click on one of the style choice options in the right-hand scrolling window.  A preview of 
that style choice will appear in the left-hand window. 
 

2. To remove all styling from your lesson, choose the Non Styled style choice option at the 
top of the right-hand window. 
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Title and Layout Style Properties 

 
 

3. After making your style selection, click the Title and Layout tab at the top of the Style 
Properties dialog.  This dialog allows you to enter a lesson title, footer, and to select 
page layout and page navigation options. 

 

 
Figure 14: Style Properties Dialog 2 Window 

 
 
4. Enter a Lesson Title and subtitle if desired.  

 
5. Customize the text for the footer as desired.  Use the checkboxes to display a copyright 

notice and date last modified if desired. 
 

6. The Page Layout option allows you select a right or left justified layout.  This selection 
will change the location of the sidebar and heading so that these appear on either the 
right or left side of the page.  Note: some styles (particularly custom styles) may not allow 
you to select a right or left justification because of the design of the style. 
 

7. The Table of Contents options allow you to choose the type of Table of Contents to be 
generated for the lesson. You may choose any of the options, all of the options, or none 
of these options.  If you choose none of the options, the Table of Contents will not be 
automatically generated. 
 

8. The Navigation options allow you specify various page navigation options for your 
lesson.  The Multi-page navigation option if chosen will display individual page numbers 
in the navigation bar at the top of the lesson page.  The On This Page sidebar option 
will display bookmark links to page headings and subheadings on the sidebar of the 
lesson page.  The Previous-Next at top of page option will display navigation arrows in 
the navigation bar at the top of the lesson page. 
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9. Click OK to save your selections.  To view the effects of your style choices, click the 
Preview button on the LessonBuilder toolbar.  This will display the lesson in your web 
browser and you will be able to view the lesson with your style choices applied. 

 
 

Creating a Multi-Page Lesson 

LessonBuilder will automatically create page navigation links for navigating within and between 
pages of a lesson, if you have enabled these options in the Style Properties dialog (see section 
above). 
 

1. To enable multi-page navigation links, you must first create a multi-page lesson.  To do 
this, simply insert pagebreaks within your lesson.  You can insert a page break anywhere 
within your lesson page by typing CTRL-ENTER (hold down the CTRL key and 
simultaneously press the ENTER key).  Alternatively, you may select Insert Pagebreak 
from the Insert menu. 
 

2. After inserting pagebreaks, preview the lesson in your web browser and observe that 
LessonBuilder has automatically created separate html files for each page of the lesson 
and automatically created between-page navigation at the top and bottom of the page. 
 

3. You can further enhance the between-page navigation at the top of the page if you create 
a page header at the top of each page.  LessonBuilder will use the first page header on a 
page to create “rollovers” for the page navigation links at the top of each styled page. 
 

4. To create a page header on a page, first type the text for the page heading.  Next, select 
the page heading text by dragging your cursor over the heading text to highlight it.  Then, 
choose Page Header from the drop-down menu in the upper-right corner of the 
LessonBuilder toolbar. 
 

 

 
Figure 15: Creating a Page Heading 

 
 

5. If you create multiple Page Headings on a styled lesson page, LessonBuilder will use the 
first Page Header on the page for the page navigation rollover title.   
 

6. If you create multiple Page Headings and subheadings on a styled lesson page, 
LessonBuilder will automatically create within page navigation and place it in a “sidebar” 
of the styled page.  (See Figure 16). 
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7. The “On this Page” sidebar page navigation is automatically created if there are two or 
more headers defined on a lesson page.   

 
 

 
Figure 16: Example of "On this Page" navigation 

 

Customizing the Sidebar 

The Sidebar in a LessonBuilder lesson allows an instructor to highlight information on the lesson 
page by placing the information in a left- or right-sidebar column on the lesson page.   
 
There are two ways to create side-bar information.  First, you can create a sidebar Table of 
Contents link and a sidebar On this Page module by making selections on the Style 
Properties/Title and Layout dialog.  (See section above titled Title and Layout Style 
Properties.)  If you have enabled these options, these sidebar components are created 
automatically by LessonBuilder and placed in the sidebar of all lesson pages. 
 
Second, you can create customized sidebar modules by choosing the Properties menu, then 
Sidebars.  There are four different types of sidebar modules that you may customize: Handouts, 
Learn More, More Resources, and Text Only.  To begin customizing a sidebar module, choose 
one of these to display the Sidebar dialog. 
 

 
Figure 17: Sidebar Dialog Window 
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The Sidebar dialog allows you to enter text into the text box that is displayed.  You may right-click 
within the text box to access the right-click menu of text formatting options.  (For example, you 
can create hyperlinks in your sidebar text using this menu.) 
 
Notice that the icon for the Sidebar module appears to the left of the text box.  The Text Only 
sidebar does not have an associated icon.  Instead, the Sidebar dialog for Text Only has a title 
dialog where you may type a title that will appear in the Sidebar module in place of the icon.  This 
allows you to customize the name your sidebar module. 
 
By default, the Sidebar module will be created for the lesson page that you were editing when you 
opened the Sidebar Dialog.  You can change the page placement of the Sidebar module, by 
modifying the For Page: option on the Sidebar Dialog.   
 
You may also copy the Sidebar module to all of your lesson pages if desired.  To do this, enter 
your Sidebar text, and then click the Copy To All Pages button on the Sidebar Dialog.   
 
To remove a Sidebar module from a page: 
 

1. Open the dialog for the Sidebar module that you wish to remove.  (For example, if 
you wish to remove the Learn More module from your page, select the dialog for that 
module.   
 

2. To remove the Sidebar module from only one page, first make certain you have the 
correct page selected by using the For Page: option on the Sidebar Dialog.   
 

3. Click the Clear Text button to remove all information from the text box.  Click OK. 
 

4. To remove the Sidebar module from all pages, click the Clear Text button to remove 
all information from the text box.  Then, click the Copy to All Pages button.  Then, 
click OK. 

 
You may insert one of each type of Sidebar module on each lesson page.  So, for example, you 
could have one each of Handouts, Learn More, More Resources, and Text Only on each 
page. 
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Custom Styles 

The Custom Style feature in LessonBuilder 3 allows the integration of additional style choices into 
your copy of LessonBuilder.  Custom Styles are created by SoftChalk; we work with you to 
develop a style that can include a customized banner, watermark, and footer and color choices.  
 
Here are two examples of custom styles that were developed for SoftChalk customers: 
 

 
Figure 18:  Example Custom Style 1 

 
 

 
Figure 19:  Example Custom style 2 
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Custom Styles are packaged as “zip” files.  To add your Custom Style package into your copy of 
LessonBuilder: 
 

1. Open LessonBuilder to a new document.  (If you are currently working in a document, 
close the document and choose File menu, New. 
 

2. Choose the Properties menu, Install Custom Style.  LessonBuilder will display a dialog 
that allows you to select your Custom Style “zip”.  You may use the standard file 
navigation options in the dialog window to locate the zip wherever it may be located on 
your computer.  Click Select to complete the file selection process. 
 

Once the custom style has been installed, you will find it listed in the Properties menu under 
Style Properties.  On the Styles tab, Custom Styles will be listed in the right-hand Style 
Choices dialog near the top of the list of style choices. 
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Lesson Reporting 

The Lesson Reporting options in LessonBuilder allow an instructor to selectively include various 
score reporting options at the end of the lesson.  To enable Lesson Reporting: 
 

1. Choose Lesson Reporting from the Properties menu. 
 

2. Score reporting options include a printed Certificate of Completion, a printed Score 
Summary, and an option to email a score summary to the instructor.  The instructor may 
choose any or all of these options to be included at the end of the lesson.  Click the 
appropriate checkbox on the Lesson Reporting dialog window to make your selections. 
 

3. Complete the appropriate dialog window options.  Different options will be available, 
depending on the options chosen in Step 2 above. 
 

4. After making your selections, click OK to save your choices.  Then, Preview the lesson in 
your web browser and view the last page of the lesson.  LessonBuilder will have 
automatically added the appropriate reporting options to your lesson, based on the 
choices made in item 2 above. 
 

5. Please note that when students print the Score Summary and Certificate of Completion, 
they will need to set their printer options to print “landscape”. 
 

6. If you chose the Email Completion Results option, the lesson results for the student will 
be emailed to the instructor using the email address provided in the Lesson Reporting 
dialog.  Please note that the student must have internet access when they are completing 
the lesson in order for the Email option to work. 

 
Lesson results can also be fed directly into the gradebook of a Course Management System 
(CMS) if the CMS is SCORM compliant, and if you package your lesson as a SCORM object.  
Please see the section on SCORM in this manual for additional information about SCORM 
options. 
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Packaging Your Lesson for Distribution 

Packaging Your Lesson 

When you have completed your lesson, use LessonBuilder’s Package feature to package the 
lesson into a “zip” file for easy portability to a web site, or to import into most course management 
systems. You may also package your lesson in a SCORM format for import into any SCORM-
compliant LMS (see next section on SCORM).  
 
Alternatively, if you wish to distribute your lesson on a CD, a file server, or a web server, simply 
copy the lesson folder (or the files from the lesson folder) onto the CD; file server, or web server.  
The lesson folder contains all of the files necessary for distribution of your lesson. 
 
To Package your lesson: 
  

1. Save the lesson before packaging it. 

2. Choose the File menu, Package lesson. 

3. There are three packaging options – standard zip, SCORM 1.2 zip, and SCORM 
2004 zip format.  Each of these options is explained below. 

4. Standard zip packaging will package your lesson into a zip file archive that contains 
your lesson and all of its associated files. 

5. SCORM zip packaging will package your lesson into a SCORM format (1.2 or 2004) 
zip package.  This format is useful if you have a SCORM-compliant Learning 
Management System.  For more information about SCORM, please see the section 
on SCORM later in this document. 

6. Once the packaging process is complete, LessonBuilder displays a message telling 
you the name of the packaged lesson zip file.  The package is always saved into the 
lesson folder where you have saved your lesson. 

7. A packaged lesson can be easily put into a course management system such as 
Blackboard or WebCT. Or, you can share the lesson with other instructors by 
emailing the zip package to them. 
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Importing Your Lesson into Blackboard or WebCT 

Instructions for importing your LessonBuilder lesson into Blackboard and WebCT can be found on 
the SoftChalk website under the “Support” area –  http://www.softchalk.com/support.html  . 

SCORM 

The Sharable Content Object Reference Model (SCORM) is a set of technical standards that 
have been developed to enable the reuse of Web-based learning content across multiple 
environments and products.  LessonBuilder supports SCORM by allowing an instructor to 
package their LessonBuilder content into a SCORM format. 
 
If your lesson content is SCORM compliant, you can use the content in any course management 
system (CMS) that supports SCORM without having to make any modifications to the content.  
Additionally, the SCORM standards allow your content to interface automatically with specific 
components of the course management system, for example the gradebook. 
 
The benefit of having a lesson in SCORM format is that the lesson score can be automatically 
recorded into the CMS gradebook.  Additionally, the CMS can track progress and completion of a 
lesson, as well as time spent on the lesson.  And a lesson that is packaged in SCORM format can 
be readily reused in many different course management systems with no need to revise the 
content. 
 
Different Course Management Systems may support different version of SCORM and may not 
fully implement the SCORM standards.  Check with your Course Management System provider 
for more information about compatibility with SCORM. 
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Need Assistance? 

If you have any problems, questions, or comments regarding installation or use of the SoftChalk 
LessonBuilder, please contact us at help@softchalk.com , or visit the web site at 
http://www.softchalk.com 
 
Thank you for your support! We hope you enjoy using SoftChalk LessonBuilder! 
 
 

COPYRIGHT Information 
 SoftChalk LessonBuilder 3 
 Copyright © 2002 2003 2004 2005 2006 SoftChalk LLC 
 All Rights Reserved.  
 =================================================== 
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